Can my Alarm System use the Alarm.com App?

If you already have or are looking for an alarm system for your home or business chances are you may be wanting to remotely arm/disarm your security system and receive text/email notifications. One of the best interactive alarm monitoring apps in the market today is the Alarm.com app. If you are looking for a compatible Alarm.com security system use our information listed below as a template. If you have any questions please feel free to contact us. 


alarm-com-compatible-panels
 

Alarm.com is compatible with the following control panels and versions:



ADT Safewatch Pro 3000All versions - Alarm.com Compatible Cell Communicator


2GIG Go! Control Alarm.com Compatible Panels

2GIG Go! Control (Older) - Panel must have a revision number of 1.9.6 + to run at least an ATT GSM module. If you want to have an LTE module you must have a rev number of 1.17 +. Compatible with 2GIG Go! Control cellular modules.

2GIG GC3 (Newer) - All versions - Compatible 2GIG GC3 ADC modules

DSC  Alarm.com Compatible Panels

DSC ImpassaThe DSC Impassa panel must be an Alarm.com DSC Version or have the internal Alarm.com cellular communicator. In order to have the Alarm.com cell module, the panel must be rev 1.30+ (This is a discontinued product and is no longer manufactured).

DSC PowerSeries (with ADC SEM Module) - PC1616, P1832, and PC1864 must have a rev number or 4.2+. Alarm.com SEM module for DSC

DSC PowerSeries Neo - Version 1.11+ - DSC Neo Alarm.com Compatible cell module

DSC Touch - All Versions (Discontinued Product)



Honeywell/Ademco Vista Alarm.com Compatible Panels -

 

The Honeywell System Enhancement Module (SEM) is compatible with the Honeywell/ADEMCO VISTA 10P, 15P, and 20P panels and the equivalents below, dating back to 2005.

Note: Panels or prom chips should work as long as they were manufactured in 2005 or later and/or above version 3.1.

To determine if the SEM is compatible with your panel, locate the date on the chip on the inside of the panel. The SEM is compatible on panel versions 2005 to present. Panels or prom chips should work as long as they were manufactured in 2005 or later and/or above version 3.1.


 All Honeywell Vista Alarm.com Compatible Model Numbers 



Honeywell Vista10p Systems

Honeywell/ADEMCO VISTA-10P

Honeywell/ADEMCO VISTA-10PSIA

First Alert FA130CP

First Alert FA130CPSIA

Honeywell Vista15p Systems

Honeywell/ADEMCO VISTA-15P

Honeywell/ADEMCO VISTA-15PSIA

First Alert FA148CP

First Alert FA148CPSIA

Honeywell Vista20p Systems

Honeywell/ADEMCO VISTA-20P

Honeywell/ADEMCO VISTA-20PSIA

First Alert FA168CPS

First Alert FA168CPSSIA

The Honeywell SEM is also compatible with the VISTA-21iP if the Internal IP/GSM Jumper is set in the OFF position.



 

 


Interlogix Alarm.com Compatible Security Systems

Simon XT - All Versions 
Simon XTI - All Versions
Simon XTI5 - All Versions

All of the Interlogix Simon Panels use the same Alarm.com Interlogix Cellular Communicators

Interlogix Concord 4 - All Versions - Concord 4 Alarm.com Compatible Communciators

Interlogix NetworX (NX) - Versions 4(v2), 6(v2), 8(v2), 8E - Compatible NX Alarm.com Cellular Modules

Qolsys Alarm.com Compatible Security Systems

Qolsys IQ Panel Classic - All Versions (Discontinued Product)

Qolsys IQ Panel 2 - All versions - Qolsys IQ Panel 2 Panel 

Once you have identified the make and model of your security system as being compatible with Alarm.com Interactive central station alarm monitoring services all you need to do is sign up, fill out the customer information form and call us for activation it's as easy as that. Please feel free to
contact us as we are always here to help.
 

Did you find this article helpful?